Author Topic: Another Windows 7 error, any fix for this one?  (Read 2132 times)

omgwtf

  • Sissy
  • *
  • Posts: 8
    • View Profile
Another Windows 7 error, any fix for this one?
« on: February 07, 2013, 01:17:30 PM »
The install went smoothly, and the first launch seemed to be working fine for a moment, then I tried to enter full-screen mode and got the critical error -

"Error setting display mode: CreateDevice failed (D3DERR_DRIVERINTERNALERROR). If you just started the game then delete your 'Postal2.ini' file and try again.  Otherwise check the Tech Support web site.

History: UD3DRenderDevice::UnSetRes <- CreateDevice <- UD3DRenderDevice::SetRes <- UWindowsViewport::TryRenderDevice <- UWindowsViewport::OpenWindow <- UGameEngine::Init <- InitEngine
"

I tried following the instruction to delete Postal2.ini, didn't seem to help a bit.

Toploader

  • Administrator
  • God Like
  • *****
  • Posts: 1691
    • View Profile
Re: Another Windows 7 error, any fix for this one?
« Reply #1 on: February 07, 2013, 02:54:32 PM »
Few things,

What are the rest of your system specs?

What version are you trying to install? (retail, Fudge pack, Steam, Desura ect).

P2 for the most part works just great on Windows 7 PC's, so we need to narrow down what it is causing your issues as it's not the OS.

prawdziwy 666

  • Lizard King
  • ***
  • Posts: 208
    • View Profile
Re: Another Windows 7 error, any fix for this one?
« Reply #2 on: February 07, 2013, 03:55:03 PM »
the same problem in this topic

http://runningwithscissors.com/main/index.php?topic=1129.0

in this topic is a solution

omgwtf

  • Sissy
  • *
  • Posts: 8
    • View Profile
Re: Another Windows 7 error, any fix for this one?
« Reply #3 on: February 07, 2013, 04:07:21 PM »
the same problem in this topic

http://runningwithscissors.com/main/index.php?topic=1129.0

in this topic is a solution


Not gonna work for me. I can't find an actual "postal2.ini" file. A search only brings up a command to delete said file or edit it, which there is no actual file that I can find to edit.
« Last Edit: February 07, 2013, 04:18:37 PM by omgwtf »

omgwtf

  • Sissy
  • *
  • Posts: 8
    • View Profile
Re: Another Windows 7 error, any fix for this one?
« Reply #4 on: February 07, 2013, 04:07:51 PM »
version

P2 STP retail disc.

specs

Windows 7 Ultimate build 7600
AsusTek model P5N-T Deluxe
Intel Pentium D 3.4Ghz
2GB RAM
Nvidia Geforce GTX 460 1GB
DirectX 11
« Last Edit: February 07, 2013, 04:22:32 PM by omgwtf »

prawdziwy 666

  • Lizard King
  • ***
  • Posts: 208
    • View Profile
Re: Another Windows 7 error, any fix for this one?
« Reply #5 on: February 07, 2013, 04:39:19 PM »
you just need to edit this file as described in this topic

omgwtf

  • Sissy
  • *
  • Posts: 8
    • View Profile
Re: Another Windows 7 error, any fix for this one?
« Reply #6 on: February 07, 2013, 04:47:38 PM »
you just need to edit this file as described in this topic

How do you edit the file if you can't find it on your system?

Ingram

  • God Like
  • *****
  • Posts: 579
    • View Profile
Re: Another Windows 7 error, any fix for this one?
« Reply #7 on: February 07, 2013, 05:47:40 PM »
If there isn't a Postal2.ini, edit Default.ini!
« Last Edit: February 07, 2013, 08:06:10 PM by Ingram »

prawdziwy 666

  • Lizard King
  • ***
  • Posts: 208
    • View Profile
Re: Another Windows 7 error, any fix for this one?
« Reply #8 on: February 07, 2013, 06:19:28 PM »
you just need to edit this file as described in this topic

How do you edit the file if you can't find it on your system?

A search only brings up a command to delete said file or edit it, which there is no actual file that I can find to edit.


 btw do you have turned on hiding of important files and folders???

 this file must be in a hidden folder
« Last Edit: February 07, 2013, 06:23:49 PM by prawdziwy 666 »

XXCLUSIVE

  • Joe Bob
  • **
  • Posts: 54
  • Postal 2 Everything Server =1409X=
    • View Profile
Re: Another Windows 7 error, any fix for this one?
« Reply #9 on: February 07, 2013, 06:35:34 PM »
Well he said in the first post that he tried deleting the file already and it still didn't work.

My advice would be to uninstall postal 2, then reinstall directX 11, then reinstall your video card drivers (you have nvidia, make sure you select clean install when you install the drivers). After that, reboot your pc, and then install postal 2... based on your specs, there is no reason why it shouldn't work.

omgwtf

  • Sissy
  • *
  • Posts: 8
    • View Profile
Re: Another Windows 7 error, any fix for this one?
« Reply #10 on: February 08, 2013, 01:52:56 PM »
Seems editing Defult.ini in the same fashion as described, it asks me to save as a new file, when I ask to replace the old with new I get "access denied". In fact I can't do anything in the folder, as I don't have permission. This is a retarded recurring problem I keep having, seeing as I AM the running administrative account but I still often get chastised for not having administrative privileges. Maybe someone could help me knock out both of these issues at once?? I've checked, and my account is set to administrator. Wtf?

Ingram

  • God Like
  • *****
  • Posts: 579
    • View Profile
Re: Another Windows 7 error, any fix for this one?
« Reply #11 on: February 08, 2013, 05:21:03 PM »
Open a terminal and go to the POSTAL2Complete directory, then: chmod +rwx. If that doesn't work use that command with sudo.

omgwtf

  • Sissy
  • *
  • Posts: 8
    • View Profile
Re: Another Windows 7 error, any fix for this one?
« Reply #12 on: February 08, 2013, 06:25:35 PM »
Alrighty, I successfully edited the default.ini and tried again and still the same error.

prawdziwy 666

  • Lizard King
  • ***
  • Posts: 208
    • View Profile
Re: Another Windows 7 error, any fix for this one?
« Reply #13 on: February 08, 2013, 10:52:12 PM »
now delete Postal2.ini the game will create a new based on defaut.ini and (I hope that) this will solve your problem

omgwtf

  • Sissy
  • *
  • Posts: 8
    • View Profile
Re: Another Windows 7 error, any fix for this one?
« Reply #14 on: February 09, 2013, 02:18:04 PM »
Still nothing. I wonder if I just install my copy of AW will it miraculously work?

EDIT: That would be a resounding NO. This sucks. This is why I hate PC gaming, a PC is a buggy piece of shite that always makes a coaster out of your old favorites.
« Last Edit: February 09, 2013, 02:26:32 PM by omgwtf »

 

Username:
Password:
Session: